2017-12-22 27 views
6

otrzymuję następujący błąd, gdy mogę wykonać mój maszynopis transpilation:TypeError podczas łyk maszynopis

TypeError: file.isSymbolic is not a function 
    at DestroyableTransform.normalize [as _transform] (D:\project\node_modules\vinyl-fs\lib\dest\prepare.js:31:15) 
    at DestroyableTransform.Transform._read (D:\project\node_modules\vinyl-fs\node_modules\readable-stream\lib\_stream_transform.js:182:10) 
    at DestroyableTransform.Transform._write (D:\project\node_modules\vinyl-fs\node_modules\readable-stream\lib\_stream_transform.js:170:83) 
    at doWrite (D:\project\node_modules\vinyl-fs\node_modules\readable-stream\lib\_stream_writable.js:406:64) 
    at writeOrBuffer (D:\project\node_modules\vinyl-fs\node_modules\readable-stream\lib\_stream_writable.js:395:5) 
    at DestroyableTransform.Writable.write (D:\project\node_modules\vinyl-fs\node_modules\readable-stream\lib\_stream_writable.js:322:11) 
    at Pumpify.Duplexify._write (D:\project\node_modules\pumpify\node_modules\duplexify\index.js:201:22) 
    at doWrite (D:\project\node_modules\pumpify\node_modules\readable-stream\lib\_stream_writable.js:406:64) 
    at writeOrBuffer (D:\project\node_modules\pumpify\node_modules\readable-stream\lib\_stream_writable.js:395:5) 
    at Pumpify.Writable.write (D:\project\node_modules\pumpify\node_modules\readable-stream\lib\_stream_writable.js:322:11) 

Moim zadaniem łyk wygląda następująco:

gulp.task('tsc', function() { 
    let tsResult = gulp.src(srcPaths.tsFiles) 
     .pipe(tsProject()); // tsProject created previously 

    return tsResult.js 
     .pipe(gulp.dest(buildPath)); // -> the gulp.dest(..) command causes the error 
}); 

package.json devDependencies (tylko łyk i TS -relevant zależności) wygląda następująco: wersja

{ 
    "devDependencies": { 
    "gulp": "github:gulpjs/gulp#4.0", 
    "gulp-sourcemaps": "^2.6.1", 
    "gulp-tslint": "^8.1.2", 
    "gulp-typescript": "^3.2.3", 
    "tslint": "^5.8.0", 
    "typescript": "^2.5.0", 
    } 
} 

Node: 8.9.3 & npm wersja: 5.6.0

Ktoś ma pomysł, co robić?

+0

Stoimy w obliczu tego samego problemu na naszym CI od kilku godzin. Wczoraj było dobrze. Nasz kod działa na starej kopii węzła_modules, ale jeśli ją wyczyszczę, nie powiedzie się. Jedyny inny wątek, jaki mogę znaleźć na ten temat, to [na chińskim forum węzłów] (https://translate.google.com/translate?sl=auto&tl=en&js=y&prev=_t&hl=en&ie=UTF-8&u=https%3A % 2F% 2Fcnodejs.org% 2Ftopic% 2F5a3cb59fd92f2f5b185ad13c & edit-text = & act = url "na chińskim forum węzłów"). Ten wpis ma 5 godzin. Zgaduję, a aktualizacja zależności uzależnia gdzieś, ale jeszcze jej nie znalazłem. – blemasle

Odpowiedz

5

Z repo haustem (issue):

phated skomentował 5 godzin temu

swoje wtyczki muszą być aktualizowane do korzystania z nowszej winylowych. Ta, której używają do tworzenia obiektów plików, jest naprawdę stara.

Jeszcze rozwiązanie tego samego problemu (działa dla mnie):

dozer75 skomentował 4 dni temu • edytowany

... Można odwołać poprzedni popełnić id zamiast nazwy oddziału po #. Ten ostatni jest 6d71a65

Powiązane problemy