5

Martwię się o tym błędzie na funkcje Firebase,funkcje Firebase uzyskać strumień błędów usunięte onCreate wydarzenie FireStore

Mam sendgrid wysyłkę na tej funkcji:

exports.mailDealings = functions.firestore 
.document('dealings/current').onCreate(event => { 
    // send mail 
    const msg = {...} 

    sgMail.send(msg); 
}) 
.catch(result => { 
    console.error("sendgrid error", result); 
}); 

udało mi się zrealizować z sukcesem wcześniej, ale na jednej rozmowy ta funkcja daje mi błąd poniżej:

{ Error: Stream removed 
    at ClientReadableStream._emitStatusIfDone (/user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:255:19) 
    at ClientReadableStream._receiveStatus (/user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:233:8) 
    at /user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:705:12 code: 2, metadata: Metadata { _internal_repr: {} } } 

Nie powinno mieć automatyczne powtórzenie tego błędu, prawda? Co najmniej metoda na to łatwe, jak na przykład result.retry(1000)?

+0

Czy jesteś pewien, że Twój kod jest poprawny? To nie wygląda na to, że obiecujesz. –

+0

To wydaje się być teraz błędem w funkcjach Firebase i jest [zaglądane] (https://groups.google.com/d/msg/firebase-talk/oza-JZMtXlo/Kge4Z0GaCQAJ). – Eric

Odpowiedz

2

Ten sam problem tutaj (w wielu funkcjach & losowo) od 3/4 dni. Podobno t znika po wdrożeniu ... przez kilka minut

Error: Stream removed 
at ClientReadableStream._emitStatusIfDone (/user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:255:19) 
at ClientReadableStream._receiveStatus (/user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:233:8) 
at /user_code/node_modules/firebase-admin/node_modules/grpc/src/client.js:705:12 
0

Z Google Groups discussion na ten błąd:

Witam wszystkich, Sebastian z zespołu Firestore SDK tutaj. Wydaje nam się, że ten numer jest związany z ostatnią aktualizacją pakietu SDK klienta GRPC i że przeprowadził testy z GRPC 1.7.1. Do tej pory nie byliśmy w stanie odtworzyć tego problemu przy użyciu starszej wersji GRPC.

@ google-cloud/firestore jest teraz na 0.10.1. Jeśli zaktualizujesz swoje zależności , będziesz mógł pobrać to wydanie.

Dziękuję za cierpliwość.

Sebastian

To zdaje się mają stałe problem dla mnie!

Powiązane problemy